UbuntuUpdates.org

Package "python-pip"

Name: python-pip

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Python package installer
  • Python package installer

Latest version: 20.0.2-5ubuntu1.6
Release: focal (20.04)
Level: updates
Repository: universe

Links



Other versions of "python-pip" in Focal

Repository Area Version
base universe 20.0.2-5ubuntu1
security universe 20.0.2-5ubuntu1.5

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 20.0.2-5ubuntu1.6 2021-07-22 03:06:23 UTC

  python-pip (20.0.2-5ubuntu1.6) focal; urgency=medium

  * Update debundle.patch so pypy uses base_prefix as well, fixing pypy
    virtualenvs. (LP: #1935882)

 -- Stefano Rivera <email address hidden> Mon, 12 Jul 2021 23:11:28 -0400

Source diff to previous version
1935882 pypy virtualenv has broken pip on focal

Version: 20.0.2-5ubuntu1.5 2021-05-19 13:06:23 UTC

  python-pip (20.0.2-5ubuntu1.5) focal-security; urgency=medium

  * Security: Don't split git references on unicode separators. (LP: #1926957)

 -- Stefano Rivera <email address hidden> Wed, 12 May 2021 21:04:29 -0400

Source diff to previous version
1926957 security fix in pip 21.1: Don't split git references on unicode separators #9827

Version: 20.0.2-5ubuntu1.4 2021-05-11 17:07:08 UTC

  python-pip (20.0.2-5ubuntu1.4) focal; urgency=medium

  * Look for pip config /etc (LP: #1914239)
  * Provide the pip binary again (LP: #1927865)

 -- Stefano Rivera <email address hidden> Sun, 09 May 2021 12:50:53 -0400

Source diff to previous version
1914239 ubuntu-20.04 pip3 ignores /etc/pip.conf
1927865 Ubuntu 20.04 missing pip binary

Version: 20.0.2-5ubuntu1.3 2021-04-26 17:06:20 UTC

  python-pip (20.0.2-5ubuntu1.3) focal; urgency=medium

  * Add Breaks: python3-virtualenv (<< 20.0.17-1ubuntu0.3) to python-pip-whl,
    which bumps the seed-app-data version. Our LP: #1880749 change broke
    existing seed-app-data caches.

Source diff to previous version
1880749 Ubuntu 20.04: virtualenv: pep517 requires toml, but it isn't bundled in venvs

Version: 20.0.2-5ubuntu1.1 2020-10-05 19:07:06 UTC

  python-pip (20.0.2-5ubuntu1.1) focal-security; urgency=medium

  * No change rebuild to pull in security fixes for urllib3

 -- Marc Deslauriers <email address hidden> Fri, 02 Oct 2020 06:58:39 -0400




About   -   Send Feedback to @ubuntu_updates