UbuntuUpdates.org

Package "snapd"




Name: snapd

Description:

Daemon and tooling that enable snap packages

Latest version: *DELETED*
Release: bionic (18.04)
Level: proposed
Repository: main
Homepage: https://github.com/snapcore/snapd

Links


Download "snapd"


Other versions of "snapd" in Bionic

Repository Area Version
base main 2.32.5+18.04
base universe 2.32.5+18.04
security main 2.48.3+18.04
security universe 2.48.3+18.04
updates main 2.51.1+18.04
updates universe 2.51.1+18.04

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: *DELETED* 2021-09-24 21:06:32 UTC
No changelog for deleted or moved packages.

Version: 2.51.1+18.04 2021-06-17 17:06:26 UTC

  snapd (2.51.1+18.04) bionic; urgency=medium

  * New upstream release, LP: #1929842
    - interfaces: add netlink-driver interface
    - interfaces: builtin: add dm-crypt interface to support external
      storage encryption
    - interfaces/dsp: fix typo in udev rule
    - overlord/snapstate: lock the mutex before returning from stop
      snap services undo
    - interfaces: opengl: change path for Xilinx zocl driver
    - interfaces/dsp: add /dev/cavalry into dsp interface
    - packaging/fedora/snapd.spec: correct date format in changelog

 -- Michael Vogt <email address hidden> Tue, 15 Jun 2021 12:45:08 +0200

1929842 [SRU] 2.51

Version: *DELETED* 2021-06-11 16:06:22 UTC
No changelog for deleted or moved packages.

Version: 2.49.2+18.04 2021-04-19 16:07:45 UTC

  snapd (2.49.2+18.04) bionic; urgency=medium

  * New upstream release, LP: #1915248
    - interfaces/tee: add TEE/OPTEE interface
    - o/configstate/configcore: add hdmi_timings to pi-config
    - interfaces/udisks2: allow locking /run/mount/utab for udisks 2.8.4
    - snap-seccomp: fix seccomp test on ppc64el
    - interfaces{,/apparmor}, overlord/snapstate:
      late removal of snap-confine apparmor profiles
    - overlord/snapstate, wrappers: add dependency on usr-lib-
      snapd.mount for services on core with snapd snap
    - o/configstate: deal with no longer valid refresh.timer=managed
    - overlord/snapstate: make sure that snapd current symlink is not
      removed during refresh
    - packaging: drop dh-systemd from build-depends on ubuntu-16.04+
    - o/{device,hook}state: encode fde-setup-request key as base64
    - snapstate: reduce reRefreshRetryTimeout to 1/2 second
    - tests/main/uc20-create-partitions: fix tests cleanup
    - o/configstate, o/snapshotstate: fix handling of nil snap config on
      snapshot restore
    - snap-seccomp: add new `close_range` syscall

 -- Michael Vogt <email address hidden> Fri, 26 Mar 2021 16:49:46 +0100

1915248 [SRU] 2.49

Version: *DELETED* 2020-12-03 16:07:05 UTC
No changelog for deleted or moved packages.



About   -   Send Feedback to @ubuntu_updates