UbuntuUpdates.org

Package "nodejs"


Moved to bionic:universe:updates


Name: nodejs

Description:

evented I/O for V8 javascript

Latest version: *DELETED*
Release: bionic (18.04)
Level: proposed
Repository: universe
Homepage: http://nodejs.org/

Links


Download "nodejs"


Other versions of "nodejs" in Bionic

Repository Area Version
base universe 8.10.0~dfsg-2
security universe 8.10.0~dfsg-2ubuntu0.2
updates universe 8.10.0~dfsg-2ubuntu0.4
PPA: Nodejs 6.x 6.14.1-1nodesource1
PPA: Nodejs 9.x 9.11.2-1nodesource1
PPA: Nodejs 12.x 12.22.7-1nodesource1
PPA: Nodejs 11.x 11.15.0-1nodesource1
PPA: Nodejs 8.x 8.17.0-1nodesource1
PPA: Nodejs 13.x 13.14.0-1nodesource1
PPA: Nodejs 10.x 10.24.1-1nodesource1
PPA: Nodejs 14.x 14.18.1-1nodesource1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: *DELETED* 2018-11-01 00:06:18 UTC
Moved to bionic:universe:updates
No changelog for deleted or moved packages.

Version: 8.10.0~dfsg-2ubuntu0.4 2018-10-18 22:06:58 UTC

  nodejs (8.10.0~dfsg-2ubuntu0.4) bionic; urgency=medium

  * Use openssl1.0 client binary in tests LP: #1798367
    - resurrect fix_sslv3_test.patch
    - revert s_client_tls12.patch, as not needed with old ssl
    - reenable-more-tests.patch - reenable openssl1.0 and zlib tests, they
      should work

 -- Dimitri John Ledkov <email address hidden> Wed, 17 Oct 2018 13:21:44 +0100

1798367 [SRU] nodejs should use openssl1.0 in testing as well

Version: *DELETED* 2018-10-01 08:07:25 UTC
Moved to bionic:universe:updates
No changelog for deleted or moved packages.

Version: 8.10.0~dfsg-2ubuntu0.3 2018-08-31 21:07:12 UTC

  nodejs (8.10.0~dfsg-2ubuntu0.3) bionic; urgency=medium

  * Force dependency on openssl1.0
    The newer openssl has ABI change, and this version of nodejs
    requires building with the older 1.0.2 version of openssl.
    (LP: #1779863)

 -- Dan Streetman <email address hidden> Mon, 23 Jul 2018 16:12:30 -0400

1779863 Ubuntu nodejs package isn't ABI compatible with mainline nodejs.



About   -   Send Feedback to @ubuntu_updates