UbuntuUpdates.org

Package "webkit2gtk"

Name: webkit2gtk

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • JavaScript engine library from WebKitGTK - GObject introspection data
  • JavaScript engine library from WebKitGTK - GObject introspection data
  • JavaScript engine library from WebKitGTK - GObject introspection data
  • Web content engine library for GTK - GObject introspection data

Latest version: 2.42.5-0ubuntu0.22.04.2
Release: jammy (22.04)
Level: security
Repository: main

Links



Other versions of "webkit2gtk" in Jammy

Repository Area Version
base universe 2.36.0-2ubuntu1
base main 2.36.0-2ubuntu1
security universe 2.42.5-0ubuntu0.22.04.2
updates universe 2.42.5-0ubuntu0.22.04.2
updates main 2.42.5-0ubuntu0.22.04.2
PPA: Ubuntu-desktop ppa 2.38.6-0ubuntu0.22.04.1+wpe1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.42.5-0ubuntu0.22.04.2 2024-02-12 14:06:54 UTC

  webkit2gtk (2.42.5-0ubuntu0.22.04.2) jammy-security; urgency=medium

  * Update to 2.42.5 to fix security issues.
    - debian/patches/fix_ftbfs.patch: fix build issue.
    - CVE-2024-23222, CVE-2024-23206, CVE-2024-23213

 -- Marc Deslauriers <email address hidden> Tue, 06 Feb 2024 07:32:42 -0500

Source diff to previous version
CVE-2024-23222 A type confusion issue was addressed with improved checks. This issue is fixed in tvOS 17.3, iOS 17.3 and iPadOS 17.3, macOS Sonoma 14.3, iOS 16.7.5
CVE-2024-23206 An access issue was addressed with improved access restrictions. This issue is fixed in watchOS 10.3, tvOS 17.3, iOS 17.3 and iPadOS 17.3, macOS Sono
CVE-2024-23213 The issue was addressed with improved memory handling. This issue is fixed in watchOS 10.3, tvOS 17.3, iOS 17.3 and iPadOS 17.3, macOS Sonoma 14.3, i

Version: 2.42.4-0ubuntu0.22.04.1 2024-01-15 16:07:05 UTC

  webkit2gtk (2.42.4-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Update to 2.42.4 to fix security issues.
    - CVE-2023-42883

 -- Marc Deslauriers <email address hidden> Tue, 09 Jan 2024 08:40:06 -0500

Source diff to previous version
CVE-2023-42883 The issue was addressed with improved memory handling. This issue is fixed in Safari 17.2, macOS Sonoma 14.2, iOS 17.2 and iPadOS 17.2, watchOS 10.2,

Version: 2.42.3-0ubuntu0.22.04.1 2023-12-11 16:09:43 UTC

  webkit2gtk (2.42.3-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Update to 2.42.3 to fix security issues.
    - CVE-2023-42916, CVE-2023-42917

 -- Marc Deslauriers <email address hidden> Wed, 06 Dec 2023 11:08:56 -0500

Source diff to previous version
CVE-2023-42916 An out-of-bounds read was addressed with improved input validation. This issue is fixed in iOS 17.1.2 and iPadOS 17.1.2, macOS Sonoma 14.1.2, Safari
CVE-2023-42917 A memory corruption vulnerability was addressed with improved locking. This issue is fixed in iOS 17.1.2 and iPadOS 17.1.2, macOS Sonoma 14.1.2, Safa

Version: 2.42.2-0ubuntu0.22.04.1 2023-11-20 17:06:57 UTC

  webkit2gtk (2.42.2-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Update to 2.42.2 to fix security issues.
    - CVE-2023-41983, CVE-2023-42852

 -- Marc Deslauriers <email address hidden> Thu, 16 Nov 2023 13:04:58 -0500

Source diff to previous version
CVE-2023-41983 The issue was addressed with improved memory handling. This issue is fixed in macOS Sonoma 14.1, Safari 17.1, iOS 16.7.2 and iPadOS 16.7.2, iOS 17.1
CVE-2023-42852 A logic issue was addressed with improved checks. This issue is fixed in iOS 17.1 and iPadOS 17.1, watchOS 10.1, iOS 16.7.2 and iPadOS 16.7.2, macOS

Version: 2.42.1-0ubuntu0.22.04.1 2023-10-10 16:07:30 UTC

  webkit2gtk (2.42.1-0ubuntu0.22.04.1) jammy-security; urgency=medium

  * Update to 2.42.1 to fix security issues.
    - debian/control.*: remove libavif-dev as there are no i386 binaries
      for it in 22.04 and it blocks the i386 build.
    - debian/control.*: remove libjxl-dev as it doesn't exist in 22.04.
    - CVE-2023-39928, CVE-2023-41074, CVE-2023-41993

 -- Marc Deslauriers <email address hidden> Wed, 04 Oct 2023 10:31:08 -0400

CVE-2023-39928 A use-after-free vulnerability exists in the MediaRecorder API of Webkit WebKitGTK 2.40.5. A specially crafted web page can abuse this vulnerability
CVE-2023-41074 The issue was addressed with improved checks. This issue is fixed in tvOS 17, Safari 17, watchOS 10, iOS 17 and iPadOS 17, macOS Sonoma 14. Processin
CVE-2023-41993 The issue was addressed with improved checks. This issue is fixed in Safari 17, iOS 16.7 and iPadOS 16.7, macOS Sonoma 14. Processing web content may



About   -   Send Feedback to @ubuntu_updates