UbuntuUpdates.org

Package "llvm-toolchain-12"




Name: llvm-toolchain-12

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • C, C++ and Objective-C compiler
  • C, C++ and Objective-C compiler - Documentation
  • Clang examples
  • Tool to format C/C++/Obj-C code

Latest version: *DELETED*
Release: focal (20.04)
Level: proposed
Repository: universe

Links



Other versions of "llvm-toolchain-12" in Focal

Repository Area Version
updates main 1:12.0.0-3ubuntu1~20.04.4
updates universe 1:12.0.0-3ubuntu1~20.04.4

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: *DELETED* 2021-09-17 17:06:22 UTC
No changelog for deleted or moved packages.

Version: 1:12.0.0-3ubuntu1~20.04.4 2021-09-04 01:06:23 UTC

  llvm-toolchain-12 (1:12.0.0-3ubuntu1~20.04.4) focal; urgency=medium

  * debian/patches/07234c7d6bc246925710b88a1f9552f678587165.patch:
    - cherry-pick upstream fix for making the compiler backend usable with
      different compilers (LP: #1935778)

 -- Gianfranco Costamagna <email address hidden> Wed, 01 Sep 2021 12:28:35 +0200

1935778 [SRU] Request LLVM 12.0.1 backport to focal/updates

Version: *DELETED* 2021-07-08 18:06:26 UTC
No changelog for deleted or moved packages.

Version: 1:12.0.0-3ubuntu1~20.04.3 2021-07-01 23:06:29 UTC

  llvm-toolchain-12 (1:12.0.0-3ubuntu1~20.04.3) focal; urgency=medium

  * control, rules: Fix build on riscv64, force gcc version to 10.
    (LP: #1925320)

 -- Timo Aaltonen <email address hidden> Wed, 23 Jun 2021 10:43:21 +0300

Source diff to previous version

Version: 1:12.0.0-3ubuntu1~20.04.1 2021-05-27 15:06:24 UTC

  llvm-toolchain-12 (1:12.0.0-3ubuntu1~20.04.1) focal; urgency=medium

  * Backport to focal. (LP: #1925320)
    - builds libclc-12/libclc-12-dev, required by mesa migrating to llvm-12
      (LP: #1928188)

 -- Timo Aaltonen <email address hidden> Wed, 12 May 2021 11:17:42 +0300

1928188 Build libclc from llvm



About   -   Send Feedback to @ubuntu_updates