UbuntuUpdates.org

Package "python-os-brick"

Name: python-os-brick

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Library for managing local volume attaches - common files
  • Library for managing local volume attaches - doc
  • Library for managing local volume attaches - Python 3.x

Latest version: 3.0.1-0ubuntu1.4
Release: focal (20.04)
Level: updates
Repository: main

Links



Other versions of "python-os-brick" in Focal

Repository Area Version
base main 3.0.1-0ubuntu1
security main 3.0.1-0ubuntu1.2

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 3.0.1-0ubuntu1.4 2022-02-01 19:06:32 UTC

  python-os-brick (3.0.1-0ubuntu1.4) focal; urgency=medium

  [ Brett Milford ]
  * Avoid unhandled exceptions during connecting to iSCSI portals
    (LP: #1915678)
    - d/p/lp1915678-avoid-unhandled-exceptions-during-connecting-to-iscsi-portals.patch

  [ Chris MacNaughton ]
  * d/control: Update VCS paths for move to lp:~ubuntu-openstack-dev.

 -- Brett Milford <email address hidden> Fri, 05 Nov 2021 10:55:06 +1000

Source diff to previous version

Version: 3.0.1-0ubuntu1.3 2020-10-12 10:06:57 UTC

  python-os-brick (3.0.1-0ubuntu1.3) focal; urgency=medium

  * d/p/lp1865754-fix-rbd-connector-for-octopus.patch: Fix RBD connector to
    work with Ceph Octopus (LP: #1865754).

 -- Chris MacNaughton <email address hidden> Wed, 23 Sep 2020 15:17:56 +0000

Source diff to previous version
1865754 [SRU] tripleo-ci-centos-8-scenario001-standalone tempest-conf fails 500 PUT http://192.168.24.1:9292/v2/images/ RADOS invalid argument

Version: 3.0.1-0ubuntu1.2 2020-07-07 16:07:08 UTC

  python-os-brick (3.0.1-0ubuntu1.2) focal-security; urgency=medium

  * d/gbp.conf: Create stable/ussuri branch.
  * SECURITY UPDATE: Dell EMC ScaleIO/VxFlex OS Backend Credentials Exposure
    (LP: #1823200)
    - debian/patches/CVE-2020-10755.patch: Remove VxFlex OS credentials
      from connection_properties. Passwords are now stored in separate file
      and are retrieved during each attach/detach operation.
    - CVE-2020-10755

 -- Corey Bryant <email address hidden> Mon, 08 Jun 2020 09:25:57 -0400

CVE-2020-10755 An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before o



About   -   Send Feedback to @ubuntu_updates