UbuntuUpdates.org

Package "update-notifier"




Name: update-notifier

Description:

Daemon which notifies about package updates

Latest version: *DELETED*
Release: bionic (18.04)
Level: proposed
Repository: main

Links


Download "update-notifier"


Other versions of "update-notifier" in Bionic

Repository Area Version
base main 3.192
updates main 3.192.1.12

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 3.192.1.10 2021-04-28 11:09:05 UTC

  update-notifier (3.192.1.10) bionic; urgency=medium

  * data/apt_check.py:
    - Add support to handle packages from ESM Apps in addition to ESM Infra
      and only display alerts if the distro is ESM. (LP: #1924766)
    - Do not display a count of ESM packages if the system does not have ESM
      enabled. (LP: #1883315)
    - Make distinction between standard security updates and ESM updates
      when performing package counts. (LP: #1926208)
    - use 'applied' instead of 'installed', redact 0 of these updates are
      security updates, and correct singular messages
  * debian/control: Add a dependency on python3-distro-info.

 -- Lucas Moura <email address hidden> Thu, 22 Apr 2021 18:39:19 -0300

1924766 update-notifier does not handle ESM Apps in the apt-check script
1883315 Showing esm update as installable when esm is disabled
1926208 standard security upgrade counts should not include ESM packages

Version: *DELETED* 2021-01-06 16:06:18 UTC
No changelog for deleted or moved packages.

Version: 3.192.1.9 2020-12-04 23:06:18 UTC

  update-notifier (3.192.1.9) bionic; urgency=medium

  * data/apt_check.py: Update UA Infra: ESM product name and doc url
    (LP: #1901627)
    - data/apt_check.py: Update name and URL
    - tests/test_motd.py: adapt unittests to match new behavior
    - po/*.po: translation files with intltool-update -r
  * Fix pep8/pyflakes autopkgtest failures (LP: #1906436)
    - d/control: add explicit pep8 build-requires dependency
    - test_motd.py: remove unused imports
    - pyflakes: data/backend_helper fix unittests for unreferenced
      variables
    - data/apt_check & data/backend_helper: resolve underindent pep8 issues
      backport of 9e0f7ee50 [ Brian Murray ]
    - data/apt_check.py, data/package-data-downloader, tests/test_pep8.py:
      + update the code formating to be not hit W504 warnings,
        change to ignore W503 and be consistent with update-manager.
        [ Andrea Azzarone ]
    - INSTALL, data/hooks.py, tests/test_package-data-downloader.py:
      Fix E117 over-indented pep issues. [ Gianfranco Costamagna ]
    - test_motd.py: Remove unused imports [ Julian Andres Klode ]
    - pyflakes: data/backend_helper fix unittests for unreferenced variables

Source diff to previous version
1901627 Update product naming: Simplify UA Infrastructure ESM to UA Infra: ESM
1906436 Resolve autopkgtest failures Pep8/pyflakes on Xenial and Bionic

Version: 3.192.1.8 2020-10-16 05:06:51 UTC

  update-notifier (3.192.1.8) bionic; urgency=medium

  [ Andreas Hasenack ]
  * data/apt_check.py: Update ESM security pockets names (LP: #1881632)
    - the UbuntuESM pocket was renamed from <distro>-security to
      <distro>-infra-security
    - new origin UbuntuESMApps, with a corresponding pocket of
      <distro>-apps-security

  [ Brian Murray ]
  * data/apt_check.py: modify wording and output regarding ESM support.
    (LP: #1842508)

  [ Julian Andres Klode ]
  * Handle missing cases of LP: #1822340, where we told people ESM is not
    enabled, but not how to enable it.
  * Fix multiple disabled ESM repositories being counted as enabled ones.

 -- Chad Smith <email address hidden> Tue, 29 Sep 2020 16:49:23 -0600

1881632 esm security updates not reported by apt update-notifier
1842508 motd messaging changes regarding apt updates
1822340 [UIFe] motd messaging rewrite

Version: *DELETED* 2019-06-06 13:08:55 UTC
No changelog for deleted or moved packages.



About   -   Send Feedback to @ubuntu_updates