UbuntuUpdates.org

Package "needrestart"

Name: needrestart

Description:

check which daemons need to be restarted after library upgrades

Latest version: 3.5-4ubuntu2.1
Release: impish (21.10)
Level: updates
Repository: main
Homepage: https://github.com/liske/needrestart

Links


Download "needrestart"


Other versions of "needrestart" in Impish

Repository Area Version
base main 3.5-4ubuntu2
security main 3.5-4ubuntu2.1

Changelog

Version: 3.5-4ubuntu2.1 2022-05-17 19:06:29 UTC

  needrestart (3.5-4ubuntu2.1) impish-security; urgency=medium

  * SECURITY UPDATE: arbitrary code exec via unanchored regexes
    - debian/patches/CVE-2022-30688.patch: improve regexes in
      perl/lib/NeedRestart/Interp/Perl.pm,
      perl/lib/NeedRestart/Interp/Python.pm,
      perl/lib/NeedRestart/Interp/Ruby.pm.
    - CVE-2022-30688

 -- Marc Deslauriers <email address hidden> Mon, 16 May 2022 07:11:57 -0400

CVE-2022-30688 local privilege escalation



About   -   Send Feedback to @ubuntu_updates