UbuntuUpdates.org

Package "libssl-doc"

Name: libssl-doc

Description:

Secure Sockets Layer toolkit - development documentation

Latest version: 1.1.1l-1ubuntu1.3
Release: impish (21.10)
Level: updates
Repository: main
Head package: openssl
Homepage: https://www.openssl.org/

Links


Download "libssl-doc"


Other versions of "libssl-doc" in Impish

Repository Area Version
base main 1.1.1l-1ubuntu1
security main 1.1.1l-1ubuntu1.3

Changelog

Version: 1.1.1l-1ubuntu1.3 2022-05-04 19:06:27 UTC

  openssl (1.1.1l-1ubuntu1.3) impish-security; urgency=medium

  * SECURITY UPDATE: c_rehash script allows command injection
    - debian/patches/CVE-2022-1292.patch: do not use shell to invoke
      openssl in tools/c_rehash.in.
    - CVE-2022-1292

 -- Marc Deslauriers <email address hidden> Tue, 03 May 2022 13:48:03 -0400

Source diff to previous version
CVE-2022-1292 The c_rehash script does not properly sanitise shell metacharacters to ...

Version: 1.1.1l-1ubuntu1.2 2022-03-15 20:07:35 UTC

  openssl (1.1.1l-1ubuntu1.2) impish-security; urgency=medium

  * SECURITY UPDATE: Infinite loop in BN_mod_sqrt()
    - debian/patches/CVE-2022-0778-1.patch: fix infinite loop in
      crypto/bn/bn_sqrt.c.
    - debian/patches/CVE-2022-0778-2.patch: add documentation of
      BN_mod_sqrt() in doc/man3/BN_add.pod.
    - debian/patches/CVE-2022-0778-3.patch: add a negative testcase for
      BN_mod_sqrt in test/bntest.c, test/recipes/10-test_bn_data/bnmod.txt.
    - CVE-2022-0778

 -- Marc Deslauriers <email address hidden> Wed, 09 Mar 2022 07:06:18 -0500

Source diff to previous version
CVE-2022-0778 Infinite loop in BN_mod_sqrt() reachable when parsing certificates

Version: 1.1.1l-1ubuntu1.1 2021-12-07 19:07:12 UTC

  openssl (1.1.1l-1ubuntu1.1) impish; urgency=medium

  * Cherry-pick upstream fixes to prevent double engine loading (LP: #1951943)

 -- Julian Andres Klode <email address hidden> Wed, 24 Nov 2021 10:53:29 +0100

1951943 Engine crashes when loading the configuration more than once



About   -   Send Feedback to @ubuntu_updates