UbuntuUpdates.org

Package "python-django"

Name: python-django

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • High-level Python web development framework (documentation)
  • High-level Python web development framework

Latest version: 2:2.2.24-1ubuntu1.4
Release: impish (21.10)
Level: security
Repository: main

Links



Other versions of "python-django" in Impish

Repository Area Version
base main 2:2.2.24-1ubuntu1
updates main 2:2.2.24-1ubuntu1.4

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2:2.2.24-1ubuntu1.4 2022-04-11 12:06:23 UTC

  python-django (2:2.2.24-1ubuntu1.4) impish-security; urgency=medium

  * SECURITY UPDATE: Potential SQL injection in QuerySet.annotate(),
    aggregate(), and extra()
    - debian/patches/CVE-2022-28346.patch: prevent SQL injection in column
      aliases in django/db/models/sql/query.py, tests/aggregation/tests.py,
      tests/annotations/tests.py, tests/queries/tests.py,
      tests/expressions/test_queryset_values.py.
    - CVE-2022-28346
  * SECURITY UPDATE: Potential SQL injection via
    QuerySet.explain(**options) on PostgreSQL
    - debian/patches/CVE-2022-28347.patch: prevent SQL injection in
      django/db/backends/postgresql/features.py,
      django/db/backends/postgresql/operations.py,
      django/db/models/sql/query.py, tests/queries/test_explain.py.
    - CVE-2022-28347

 -- Marc Deslauriers <email address hidden> Tue, 05 Apr 2022 12:28:21 -0400

Source diff to previous version
CVE-2022-28346 Potential SQL injection in QuerySet.annotate(), aggregate(), and extra()
CVE-2022-28347 Potential SQL injection via QuerySet.explain(**options) on PostgreSQL

Version: 2:2.2.24-1ubuntu1.3 2022-02-03 14:08:20 UTC

  python-django (2:2.2.24-1ubuntu1.3) impish-security; urgency=medium

  * SECURITY UPDATE: possible XSS via debug template tag
    - debian/patches/CVE-2022-22818.patch: properly encode the current
      context in django/template/defaulttags.py,
      tests/template_tests/syntax_tests/test_debug.py,
      tests/template_tests/tests.py.
    - CVE-2022-22818
  * SECURITY UPDATE: denial-of-service possibility in file uploads
    - debian/patches/CVE-2022-23833.patch: fix infinite loop in
      django/http/multipartparser.py, tests/file_uploads/tests.py.
    - CVE-2022-23833

 -- Marc Deslauriers <email address hidden> Tue, 01 Feb 2022 10:02:39 -0500

Source diff to previous version
CVE-2022-22818 The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3 ...
CVE-2022-23833 An issue was discovered in MultiPartParser in Django 2.2 before 2.2.27 ...

Version: 2:2.2.24-1ubuntu1.2 2022-01-05 14:06:28 UTC

  python-django (2:2.2.24-1ubuntu1.2) impish-security; urgency=medium

  * SECURITY UPDATE: Denial-of-service possibility in
    UserAtributeSimilarityValidator
    - debian/patches/CVE-2021-45115.patch: prevent DoS in
      django/contrib/auth/password_validation.py,
      docs/topics/auth/passwords.txt, tests/auth_tests/test_validators.py.
    - CVE-2021-45115
  * SECURITY UPDATE: Potential information disclosure in dictsort template
    filter
    - debian/patches/CVE-2021-45116.patch: properly handle private
      variables in django/template/defaultfilters.py,
      docs/ref/templates/builtins.txt,
      tests/template_tests/filter_tests/test_dictsort.py,
      tests/template_tests/filter_tests/test_dictsortreversed.py.
    - CVE-2021-45116
  * SECURITY UPDATE: Potential directory-traversal via Storage.save()
    - debian/patches/CVE-2021-45452.patch: fix path traversal in
      django/core/files/storage.py,
      tests/file_storage/test_generate_filename.py,
      tests/file_storage/tests.py.
    - CVE-2021-45452

 -- Marc Deslauriers <email address hidden> Tue, 04 Jan 2022 07:15:17 -0500

Source diff to previous version
CVE-2021-45115 An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11 ...
CVE-2021-45116 An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11 ...
CVE-2021-45452 Storage.save in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 b ...

Version: 2:2.2.24-1ubuntu1.1 2021-12-07 14:06:57 UTC

  python-django (2:2.2.24-1ubuntu1.1) impish-security; urgency=medium

  * SECURITY UPDATE: potential bypass of an upstream access control based on
    URL paths
    - debian/patches/CVE-2021-44420.patch: fix path match in
      django/urls/resolvers.py, tests/urlpatterns/tests.py.
    - CVE-2021-44420

 -- Marc Deslauriers <email address hidden> Tue, 30 Nov 2021 06:56:31 -0500

CVE-2021-44420 Potential bypass of an upstream access control based on URL paths



About   -   Send Feedback to @ubuntu_updates