UbuntuUpdates.org

Package "libwbclient0"

Name: libwbclient0

Description:

Samba winbind client library

Latest version: 2:4.13.14+dfsg-0ubuntu0.21.10.4
Release: impish (21.10)
Level: security
Repository: main
Head package: samba
Homepage: http://www.samba.org

Links


Download "libwbclient0"


Other versions of "libwbclient0" in Impish

Repository Area Version
base main 2:4.13.5+dfsg-2ubuntu2
updates main 2:4.13.14+dfsg-0ubuntu0.21.10.4

Changelog

Version: 2:4.13.14+dfsg-0ubuntu0.21.10.4 2021-12-13 21:07:25 UTC

  samba (2:4.13.14+dfsg-0ubuntu0.21.10.4) impish-security; urgency=medium

  * SECURITY REGRESSION: Kerberos authentication on standalone server in
    MIT realm broken
    - debian/patches/bug14922.patch: fix MIT Realm regression in
      source3/auth/user_krb5.c.

 -- Marc Deslauriers <email address hidden> Mon, 13 Dec 2021 07:11:23 -0500

Source diff to previous version

Version: 2:4.13.14+dfsg-0ubuntu0.21.10.3 2021-12-06 16:06:23 UTC

  samba (2:4.13.14+dfsg-0ubuntu0.21.10.3) impish-security; urgency=medium

  * SECURITY REGRESSION: undesired side effects for the local nt token
    - debian/patches/bug14901-*.patch: upstream patches to fix some
      mapping issues.
  * SECURITY REGRESSION: backup command raises FileNotFoundError
    (LP: #1952187)
    - debian/patches/bug14918-*.patch: upstream patches to properly handle
      dangling symlinks.

 -- Marc Deslauriers <email address hidden> Thu, 02 Dec 2021 07:56:37 -0500

Source diff to previous version
1952187 backup command raises FileNotFoundError

Version: 2:4.13.14+dfsg-0ubuntu0.21.10.1 2021-11-11 13:06:49 UTC

  samba (2:4.13.14+dfsg-0ubuntu0.21.10.1) impish-security; urgency=medium

  * Update to 4.13.14 as a security update (LP: #1950363)
    - debian/patches/CVE-2021-20254.patch: removed, included in new
      version.
    - debian/control: bump ldb Build-Depends to 2.2.3.
    - debian/samba-libs.install: added libdcerpc-pkt-auth.so.0.
    - debian/patches/trusted_domain_regression_fix.patch: fix regression
      introduced in 4.13.14.
    - CVE-2016-2124, CVE-2020-25717, CVE-2020-25718, CVE-2020-25719,
      CVE-2020-25721, CVE-2020-25722, CVE-2021-3738, CVE-2021-23192

 -- Marc Deslauriers <email address hidden> Tue, 09 Nov 2021 14:52:07 -0500

1950363 Nov 2021 security update tracking bug
CVE-2021-20254 Negative idmap cache entries can cause incorrect group entries in the Samba file server process token
CVE-2016-2124 SMB1 client connections can be downgraded to plaintext authentication
CVE-2020-25717 A user on the domain can become root on domain members
CVE-2020-25718 An RODC can issue (forge) administrator tickets to other servers
CVE-2020-25719 AD DC Username based races when no PAC is given
CVE-2020-25721 [Kerberos acceptors need easy access to stable AD identifiers (eg objectSid)
CVE-2020-25722 AD DC UPN vs samAccountName not checked
CVE-2021-3738 crash in dsdb stack
CVE-2021-23192 dcerpc requests don't check all fragments against the first auth_state



About   -   Send Feedback to @ubuntu_updates