UbuntuUpdates.org

Package "exiv2"

Name: exiv2

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • EXIF/IPTC/XMP metadata manipulation library
  • EXIF/IPTC/XMP metadata manipulation library - development files
  • EXIF/IPTC/XMP metadata manipulation library - HTML documentation

Latest version: 0.27.3-3ubuntu4.1
Release: impish (21.10)
Level: security
Repository: main

Links



Other versions of "exiv2" in Impish

Repository Area Version
base main 0.27.3-3ubuntu4
base universe 0.27.3-3ubuntu4
security universe 0.27.3-3ubuntu4.1
updates main 0.27.3-3ubuntu4.1
updates universe 0.27.3-3ubuntu4.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.27.3-3ubuntu4.1 2022-01-11 14:07:19 UTC

  exiv2 (0.27.3-3ubuntu4.1) impish-security; urgency=medium

  * SECURITY REGRESSION: out of range access that may cause a crash
    - debian/patches/CVE-2021-37620-4.patch: fix out of range access that may
      cause a crash (LP: #1941752)
    - debian/patches/CVE-2021-37620-5.patch: backport to C++98 (a str.pop_back
      that was added in C++11)
    - Thanks Simon Schmeißer

 -- Leonidas Da Silva Barbosa <email address hidden> Mon, 10 Jan 2022 10:28:12 -0300

1941752 Regression: exiv2 0.27.3-3ubuntu1.5 makes Gwenview crash when opening images exported by darktable
CVE-2021-37620 Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was



About   -   Send Feedback to @ubuntu_updates