UbuntuUpdates.org

Package "bind9"

Name: bind9

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Transitional package for bind9-utils
  • Transitional package for bind9-dnsutils

Latest version: 1:9.16.8-1ubuntu3.3
Release: hirsute (21.04)
Level: updates
Repository: universe

Links



Other versions of "bind9" in Hirsute

Repository Area Version
base main 1:9.16.8-1ubuntu3
base universe 1:9.16.8-1ubuntu3
security main 1:9.16.8-1ubuntu3.3
security universe 1:9.16.8-1ubuntu3.3
updates main 1:9.16.8-1ubuntu3.3

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:9.16.8-1ubuntu3.3 2021-10-28 21:06:25 UTC

  bind9 (1:9.16.8-1ubuntu3.3) hirsute-security; urgency=medium

  * SECURITY UPDATE: resolver performance degradation via lame cache abuse
    - debian/patches/CVE-2021-25219.patch: disable lame cache in
      bin/named/config.c, bin/named/server.c, lib/dns/resolver.c.
    - CVE-2021-25219

 -- Marc Deslauriers <email address hidden> Wed, 27 Oct 2021 06:57:43 -0400

Source diff to previous version
CVE-2021-25219 In BIND 9.3.0 -&gt; 9.11.35, 9.12.0 -&gt; 9.16.21, and versions 9.9.3- ...

Version: 1:9.16.8-1ubuntu3.1 2021-04-29 14:06:31 UTC

  bind9 (1:9.16.8-1ubuntu3.1) hirsute-security; urgency=medium

  * SECURITY UPDATE: DoS via broken inbound incremental zone update (IXFR)
    - debian/patches/CVE-2021-25214.patch: immediately reject the entire
      transfer for certain RR in lib/dns/xfrin.c.
    - CVE-2021-25214
  * SECURITY UPDATE: assert via answering certain queries for DNAME records
    - debian/patches/CVE-2021-25215.patch: fix assert checks in
      lib/ns/query.c.
    - CVE-2021-25215
  * SECURITY UPDATE: overflow in BIND's GSSAPI security policy negotiation
    - debian/rules: build with --disable-isc-spnego to disable internal
      SPNEGO and use the one from the kerberos libraries.
    - CVE-2021-25216

 -- Marc Deslauriers <email address hidden> Tue, 27 Apr 2021 07:07:30 -0400

CVE-2021-25214 In BIND 9.8.5 -&gt; 9.8.8, 9.9.3 -&gt; 9.11.29, 9.12.0 -&gt; 9.16.13, ...
CVE-2021-25215 In BIND 9.0.0 -&gt; 9.11.29, 9.12.0 -&gt; 9.16.13, and versions BIND 9 ...
CVE-2021-25216 In BIND 9.5.0 -&gt; 9.11.29, 9.12.0 -&gt; 9.16.13, and versions BIND 9 ...



About   -   Send Feedback to @ubuntu_updates