UbuntuUpdates.org

Package "libcaca"

Name: libcaca

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • text mode graphics utilities

Latest version: 0.99.beta19-2.1ubuntu1.20.10.1
Release: groovy (20.10)
Level: security
Repository: universe

Links



Other versions of "libcaca" in Groovy

Repository Area Version
base universe 0.99.beta19-2.1ubuntu1
base main 0.99.beta19-2.1ubuntu1
security main 0.99.beta19-2.1ubuntu1.20.10.1
updates main 0.99.beta19-2.1ubuntu1.20.10.1
updates universe 0.99.beta19-2.1ubuntu1.20.10.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.99.beta19-2.1ubuntu1.20.10.1 2021-04-20 18:07:30 UTC

  libcaca (0.99.beta19-2.1ubuntu1.20.10.1) groovy-security; urgency=medium

  * SECURITY UPDATE: Buffer overflow
    - debian/patches/CVE-2021-3410-*.patch: in canvas fix a integer overflow
      in caca_resize() and change some unit tests with that change in
      caca/canvas.c, caca/codec/import.c, caca/codec/text.c, test/canvas.cpp,
      tools/makefont.c.
    - CVE-2021-3410

 -- Leonidas Da Silva Barbosa <email address hidden> Mon, 05 Apr 2021 13:29:40 -0300

CVE-2021-3410 A flaw was found in libcaca v0.99.beta19. A buffer overflow issue in caca_resize function in libcaca/caca/canvas.c may lead to local execution of arb



About   -   Send Feedback to @ubuntu_updates