UbuntuUpdates.org

Package "python-eventlet"

Name: python-eventlet

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • concurrent networking library - doc
  • concurrent networking library

Latest version: 0.26.1-0ubuntu1.1
Release: groovy (20.10)
Level: security
Repository: main

Links



Other versions of "python-eventlet" in Groovy

Repository Area Version
base main 0.26.1-0ubuntu1
updates main 0.26.1-0ubuntu1.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.26.1-0ubuntu1.1 2021-05-17 14:06:28 UTC

  python-eventlet (0.26.1-0ubuntu1.1) groovy-security; urgency=medium

  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2021-21419.patch: limit maximum uncompressed
      frame length to 8MiB in eventlet/websocket.py,
      tests/websocket_new_test.py.
    - CVE-2021-21419

 -- Leonidas Da Silva Barbosa <email address hidden> Tue, 11 May 2021 11:32:51 -0300

CVE-2021-21419 Eventlet is a concurrent networking library for Python. A websocket peer may exhaust memory on Eventlet side by sending very large websocket frames.



About   -   Send Feedback to @ubuntu_updates