UbuntuUpdates.org

Package "gdk-pixbuf"

Name: gdk-pixbuf

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • GDK Pixbuf library - GObject-Introspection
  • GDK Pixbuf library
  • GDK Pixbuf library (thumbnailer)
  • GDK Pixbuf library - data files

Latest version: 2.40.0+dfsg-5ubuntu0.2
Release: groovy (20.10)
Level: security
Repository: main

Links



Other versions of "gdk-pixbuf" in Groovy

Repository Area Version
base main 2.40.0+dfsg-5
base universe 2.40.0+dfsg-5
security universe 2.40.0+dfsg-5ubuntu0.2
updates main 2.40.0+dfsg-5ubuntu0.2
updates universe 2.40.0+dfsg-5ubuntu0.2

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.40.0+dfsg-5ubuntu0.2 2021-02-22 16:06:24 UTC

  gdk-pixbuf (2.40.0+dfsg-5ubuntu0.2) groovy-security; urgency=medium

  * SECURITY UPDATE: integer underflow in GIF loader
    - debian/patches/CVE-2021-20240.patch: check for overflow in
      gdk-pixbuf/io-gif-animation.c.
    - CVE-2021-20240

 -- Marc Deslauriers <email address hidden> Thu, 18 Feb 2021 09:39:36 -0500

Source diff to previous version
CVE-2021-20240 integer underflow in the GIF loader of gdk-pixbuf via crafted input leads to segmentation fault

Version: 2.40.0+dfsg-5ubuntu0.1 2020-12-08 17:07:12 UTC

  gdk-pixbuf (2.40.0+dfsg-5ubuntu0.1) groovy-security; urgency=medium

  * SECURITY UPDATE: infinite loop in write_indexes
    - debian/patches/CVE-2020-29385.patch: fix LZW decoder accepting
      invalid LZW code in gdk-pixbuf/lzw.c.
    - CVE-2020-29385

 -- Marc Deslauriers <email address hidden> Tue, 08 Dec 2020 08:30:38 -0500

CVE-2020-29385 RESERVED



About   -   Send Feedback to @ubuntu_updates